I have actually a s10 the the fuel pump wont pump. Put in a new fuel pump and it pump because that a few secs and also quit. Every wires test good and no shorts. Poor relay?


You are watching: 2000 chevy s10 fuel pump relay location

*

that does sounds like the relay is poor but to it is in sure below is a guide to assist you action by step with accuse in the diagrams listed below to present you exactly how on her car.https://www.centregalilee.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuitCheck out the diagrams (Below). Permit us know what happens and also please upload images or videos that the problem.
*

*

*

*

correctly I placed in a jumper at the relay and also the fuel pump will run. I put in a brand-new relay and it addressed it thank you because that the guide.
Fuel pump no working. Have replaced it v a new one, no luck. No voltage at grey wire to pump.Have swapped the end the relay, no luckHave examine the fuse alongside the relay, okay. There is voltage at the fuse (test light)I have actually read there is a place where you can test the circuit by giving a 12 volts jumper which need to then cause the pump to operation (or tell you over there is a problem like a damaged line - grey wire). Yet I don't understand where this is.Assuming the line is okay to the pump, what to be I absent that is keeping the pump from gaining power?The engine has actually spark and also so on. Does not run. No code comes up via the scanner.
an excellent morning, fastened a cable diagram because that you come view. Please verify powers to the relay v the key on for me and also let me recognize the voltage.The primer wire you room talking about was for the older models and is not in your truck.Roy
for this reason voltage at the ECM B fuse v the fuse removed and also the relay in place?Or fuse in place and also relay removed?(Or both, due to the fact that I'll be ideal there?)Thanks!
Fuse in place. Test for strength to pen 30. The other, 86, should only have actually voltage with the crucial on for 2 secs as it comes from the pcm. The will keep voltage if cranking.If you run 30 and 87, the pump have to run.Roy
This provides sense.My just confusion is ~ above the to know of the 4 pins. If i unplug the relay, I believe the pins are in a rectangle-shaped set-up vice versa, the illustration you detailed has castle in a linear collection up.I carry out recall finding voltage at one of them with the key on.So looking down at wherein the relay to be removed, from the driver's next fender, that is who?Thank you! man
Look in ~ the bottom that the relay. They need to be significant 30, 87, 86, 85.You jump the 12-volt power or pen 30 to 87 i m sorry is the gray wire to the pump.Roy
Okay! We obtained it running. The grounds for the computer and also other electrical's to be rusted and not working. 218,000 mile in new England walk that, sadly.Thanks because that the great information. We have printed it every up and tucked the away because that future reference. John
Fuel pump just stopped take it it the end of the tank inspect the relations an no power, checked the relay & fuses all good, have actually power at the relay, tryed another relay an still no strength at the pump, what am i missing?
The computer energizes the fuel pump relay and relay will certainly de-energized in 2secs. In ~ which time once the automobile fires up the oil push sending unit strength the pump-All you got is 2secs to inspect for strength at the connector. Additionally see below

*


Engine turns over yet will no start. Did no hear fuel pump running when ignition is only in on position. Confirm fuses and also fuel pump relay. Deserve to hear the fuel pump relay click as soon as the ECM B fuse is put with the ignition in the top top position. Changed fuel pump. Quiet behaves the very same way.


See more: 2013 Subaru Impreza Lug Nut Torque Specs, Subaru Lug Nut Torque Specs Table

I completely forgot to walk in here and also update this short article after I addressed the problem. I was going with some old e-mail and saw whereby I had signed up for this forum and also realized the I never updated it. So right here goes. End a year later. However, the trouble was addressed in a couple of days! I had taken the bed off of the truck to make it easier to change the fuel pump. After instead of the fuel pump i tried to begin the truck. No luck, same as before. Acquiring to the point of providing up. Ns went ahead and put the truck bed earlier on again. I simply happened come be sit in the motorists seat simply wondering what in the civilization could it is in wrong as soon as I reached down and also for some reason just turned the key. The started! The only thing ns can number is that there was a ground wire that required to be associated that wasn"t as soon as the bed had been off. Yet anyway, the new fuel pump did deal with the problem and the truck has run an excellent this past year.