JavaScript is disabled. For a better experience, please enable JavaScript in your browser before proceeding.


You are watching: 2001 dodge dakota o2 sensor locations

I am trying to confirm which o2 sensor is (bank 2 sensor 2) on my 01 Dakota 4.7. I was told it is the one in the rear on the driver"s side. I have replaced it but still am getting a code. First it was P0158 now it is P0161. Different codes but both are for bank 2 sensor 2. Thanks for any help!
2001 SLT QCH.O. cams & Intake, BBK 70MM, Flowtech headers, Mopar 4.11, Auburn LSD, 360 Air Intakez, Hotchkis TVS w/Bilsteins, WC lower control arms...
*

Thanks guys...that"s what I was afraid of. Any idea if the bank 2 sensor 2 and bank 1 sensor 1 can be interchanged or are they unique?
Thanks guys...that"s what I was afraid of. Any idea if the bank 2 sensor 2 and bank 1 sensor 1 can be interchanged or are they unique?
The sensor is the same. The right side (passenger) has a shorter wire than the left side (drivers). The one you have will work but you may have to tie up the extra length of wire to keep it off he pipes.bwdakrt
had a quick question, is the o2 sensor using an 18 mm bung? ThanksI ordered a new y pipe so i need to get 4 new bungs for all the sensors.
Removed snorkle, KN drop in, 3.5 mandrel bent intake tube, 68.5mm fastman throttle body, 2002 HO manifold, HO cams, stan"s headers w/custom 2.25" mandrel bent Y pipe into 3" single, Non fouler o2 simms for missing pre cats, magnaflow high flow cat, magnaflow dumped after axle, no clutch fan, superchips, 4.10"s with auburn limited slip. :rockwoot:
If I"m not mistaken, I believe ALL O2 sensors have a 14mm x 1.5 pitch thread. Maybe some of these guys can correct me if I"m wrong.bwdakrt
Removed snorkle, KN drop in, 3.5 mandrel bent intake tube, 68.5mm fastman throttle body, 2002 HO manifold, HO cams, stan"s headers w/custom 2.25" mandrel bent Y pipe into 3" single, Non fouler o2 simms for missing pre cats, magnaflow high flow cat, magnaflow dumped after axle, no clutch fan, superchips, 4.10"s with auburn limited slip. :rockwoot:
*

I have replaced both sensors, and am still getting a code, i think my convertor is crapped out. Where can I get a new one for a reasonable price? I checked out summit but there are some pricey ones....and its CA truck
*

BTW, did changing the senors on the passenger side solve your problem? I have exact same situation but same code after changing sensors. I bought DENSO ones but maybe I will need Bosch......:huh:
*
Continue with Google
A forum community dedicated to all Dodge Dakota and Durango owners and enthusiasts. Come join the discussion about modifications, troubleshooting, towing capacity, maintenance, and more!


See more: Wiring Two Baseboard Heaters To One Thermostat ? King Electric

General Automotive DiscussionTroubleshooter's Forum4.7L/4.7L HO/4.7L Gen II EnginesSuspensions - Lifted & LoweredWheels, Tires & Brakes